use strict;
my $str = '<video id="cb_video_js" class="video-js vjs-default-skin" width="320px" height="240px" poster="http://192.168.0.116/files/thumbs/High.Res.02/1507360901c8cef-1.jpg" >
<source src=\'http://192.168.0.116/files/videos/High.Res.02/1507360901c8cef-480.mp4\' type="video/mp4" data-res="480" />
<source src=\'http://192.168.0.116/files/videos/High.Res.02/1507360901c8cef-720.mp4\' type="video/mp4" data-res="720" />
<p class="vjs-no-js">To view this video please enable JavaScript, and consider upgrading to a web browser that <a href="http://videojs.com/html5-video-support/" target="_blank">supports HTML5 video</a></p>';
my $regex = qr/src='(.+?)' type="video/mp4" data-res="(.+?)" />/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}