# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"src='(.+?)' type=\"video/mp4\" data-res=\"(.+?)\" />"
test_str = ("<video id=\"cb_video_js\" class=\"video-js vjs-default-skin\" width=\"320px\" height=\"240px\" poster=\"http://192.168.0.116/files/thumbs/High.Res.02/1507360901c8cef-1.jpg\" >\n"
"<source src='http://192.168.0.116/files/videos/High.Res.02/1507360901c8cef-480.mp4' type=\"video/mp4\" data-res=\"480\" />\n"
"<source src='http://192.168.0.116/files/videos/High.Res.02/1507360901c8cef-720.mp4' type=\"video/mp4\" data-res=\"720\" />\n"
"<p class=\"vjs-no-js\">To view this video please enable JavaScript, and consider upgrading to a web browser that <a href=\"http://videojs.com/html5-video-support/\" target=\"_blank\">supports HTML5 video</a></p>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.