#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?'number'\d+)\t(?'description'.+?)(?=^\d|\Z)"
Local $sString = "# description" & @CRLF & _
"1 first item" & @CRLF & _
"2 second ite3m on two or" & @CRLF & _
" more lines of text" & @CRLF & _
"3 third item"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")