$re = '/(?\'number\'\d+)\t(?\'description\'.+?)(?=^\d|\Z)/ms';
$str = '# description
1 first item
2 second ite3m on two or
more lines of text
3 third item';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);