const regex = /(?'number'\d+)\t(?'description'.+?)(?=^\d|\Z)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?\'number\'\\d+)\\t(?\'description\'.+?)(?=^\\d|\\Z)', 'gms')
const str = `# description
1 first item
2 second ite3m on two or
more lines of text
3 third item`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}