using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?'number'\d+)\t(?'description'.+?)(?=^\d|\Z)";
string input = @"# description
1 first item
2 second ite3m on two or
more lines of text
3 third item";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}