package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\n|^)([^-].*)\n-\s`)
var str = `Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque
- red
- green
- blue
Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque
ac adipiscing mauris ante class placerat per sem quisque phasellus sociosqu, mollis
- red
- green
- blue
bluorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque`
var substitution = "$1$2\n\n- "
fmt.Println(re.ReplaceAllString(str, substitution))
}