$re = '/(\n|^)([^-].*)\n-\s/';
$str = 'Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque
- red
- green
- blue
Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque
ac adipiscing mauris ante class placerat per sem quisque phasellus sociosqu, mollis
- red
- green
- blue
bluorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque';
$subst = "$1$2\n\n- ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;