import Foundation
let pattern = #"(\n|^)([^-].*)\n-\s"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque
- red
- green
- blue
Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque
ac adipiscing mauris ante class placerat per sem quisque phasellus sociosqu, mollis
- red
- green
- blue
bluorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2\n\n- "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)