# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\n|^)([^-].*)\n-\s"
test_str = ("Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque\n"
"- red\n"
"- green\n"
"- blue\n"
"Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque\n"
"ac adipiscing mauris ante class placerat per sem quisque phasellus sociosqu, mollis\n"
"- red\n"
"- green\n"
"- blue\n"
"bluorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque")
subst = "$1$2\\n\\n- "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.