using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>bnd\d{0,3}?)_(?<secondaryId>all|0[1-9]|[1-9][1-9])(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$";
string input = @"Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_all_r1.indd
Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_01_r1.indd
Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_11_r1.indd
Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_111_r1.indd
Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_00_r1.indd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}