const regex = /^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>bnd\d{0,3}?)_(?<secondaryId>all|0[1-9]|[1-9][1-9])(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)\\\/(?<mnemonic>.{2,8}?)_(?<isbn>\\d{13})_(?<primaryId>bnd\\d{0,3}?)_(?<secondaryId>all|0[1-9]|[1-9][1-9])(?:_r(?<revisionNumber>\\d+))?\\.(?<extension>indd|qxp|qxd)$', 'gm')
const str = `Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_all_r1.indd
Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_01_r1.indd
Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_11_r1.indd
Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_111_r1.indd
Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_00_r1.indd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}