re = /^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>bnd\d{0,3}?)_(?<secondaryId>all|0[1-9]|[1-9][1-9])(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$/m
str = 'Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_all_r1.indd
Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_01_r1.indd
Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_11_r1.indd
Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_111_r1.indd
Obam_9781524763138_bnd_all_r3 Folder/Links/Obam_9781524763138_bnd_00_r1.indd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end