$re = '/<s((pan)?(up)?)[^>]*>.+<\/s\1>/i';
$str = '<span> foo</span>
<sup> foo</sup>
<span> foo</span>
<sup> foo</sup>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);