#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=^|\n)(?<num>#+)\s+(?<header>[^\n]+)"
Local $sString = "# August 2024 News And Updates" & @CRLF & _
"## Sports" & @CRLF & _
"### Basketball" & @CRLF & _
"Optional related content & text.." & @CRLF & _
"### Ping Pong" & @CRLF & _
"Optional related content & text.." & @CRLF & _
"## Business" & @CRLF & _
"### Technology" & @CRLF & _
"Optional related content & text.." & @CRLF & _
"# News From Last Week" & @CRLF & _
"## Business" & @CRLF & _
"### Technology" & @CRLF & _
"Optional related content & text.." & @CRLF & _
"## Arts"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")