import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|\\n)(?<num>#+)\\s+(?<header>[^\\n]+)";
final String string = "# August 2024 News And Updates\n"
+ "## Sports\n"
+ "### Basketball\n"
+ "Optional related content & text..\n"
+ "### Ping Pong\n"
+ "Optional related content & text..\n"
+ "## Business\n"
+ "### Technology\n"
+ "Optional related content & text..\n"
+ "# News From Last Week\n"
+ "## Business\n"
+ "### Technology\n"
+ "Optional related content & text..\n"
+ "## Arts";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}