$re = '/(?<=^|\n)(?<num>#+)\s+(?<header>[^\n]+)/';
$str = '# August 2024 News And Updates
## Sports
### Basketball
Optional related content & text..
### Ping Pong
Optional related content & text..
## Business
### Technology
Optional related content & text..
# News From Last Week
## Business
### Technology
Optional related content & text..
## Arts';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);