const regex = /(?<=^|\n)(?<num>#+)\s+(?<header>[^\n]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|\\n)(?<num>#+)\\s+(?<header>[^\\n]+)', 'g')
const str = `# August 2024 News And Updates
## Sports
### Basketball
Optional related content & text..
### Ping Pong
Optional related content & text..
## Business
### Technology
Optional related content & text..
# News From Last Week
## Business
### Technology
Optional related content & text..
## Arts`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}