using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(...{9})$";
string input = @"Your entry, named ""test_entr"", has successfully been created with the reference ""123A5XY89""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}