import re
regex = re.compile(r"(...{9})$")
test_str = "Your entry, named \"test_entr\", has successfully been created with the reference \"123A5XY89\""
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")