$re = '/(...{9})$/';
$str = 'Your entry, named "test_entr", has successfully been created with the reference "123A5XY89"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);