const regex = /(...{9})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(...{9})$', '')
const str = `Your entry, named "test_entr", has successfully been created with the reference "123A5XY89"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}