package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*)\s+(?P<log_time>.*),Microsoft-Windows-Security-Auditing,(?P<event_id>\d+),(?P<category>.*),(?P<event_message>.*)\s+(?P<audit_message>.*)`)
var str = `Audit Success,08/03/2017 18:57:56,Microsoft-Windows-Security-Auditing,4608,Security State Change,"Windows is starting up.
This event is logged when LSASS.EXE starts and the auditing subsystem is initialized."`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}