import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*)\\s+(?P<log_time>.*),Microsoft-Windows-Security-Auditing,(?P<event_id>\\d+),(?P<category>.*),(?P<event_message>.*)\\s+(?P<audit_message>.*)";
final String string = "Audit Success,08/03/2017 18:57:56,Microsoft-Windows-Security-Auditing,4608,Security State Change,\"Windows is starting up.\n\n"
+ "This event is logged when LSASS.EXE starts and the auditing subsystem is initialized.\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}