using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:,|^)\s*([^\s=]+)\s*=\s*('[^']*'|\S+)";
string input = @"col1 = 'Test String' , col2= 'Next Test String',col3='Last Text String', col4=37";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}