const regex = /(?:,|^)\s*([^\s=]+)\s*=\s*('[^']*'|\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:,|^)\\s*([^\\s=]+)\\s*=\\s*(\'[^\']*\'|\\S+)', 'gm')
const str = `col1 = 'Test String' , col2= 'Next Test String',col3='Last Text String', col4=37`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}