$re = '/(?:,|^)\s*([^\s=]+)\s*=\s*(\'[^\']*\'|\S+)/m';
$str = 'col1 = \'Test String\' , col2= \'Next Test String\',col3=\'Last Text String\', col4=37';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);