re = /(?:,|^)\s*([^\s=]+)\s*=\s*('[^']*'|\S+)/m
str = 'col1 = \'Test String\' , col2= \'Next Test String\',col3=\'Last Text String\', col4=37'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end