using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{2}-\d{7}$|\d{9}|\d{3}(?<sep>[-\s])\d{2}\k<sep>\d{4}";
string input = @"12-3456789
123456789
123 45 6789
123-45-6789";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}