re = /^\d{2}-\d{7}$|\d{9}|\d{3}(?<sep>[-\s])\d{2}\k<sep>\d{4}/m
str = '12-3456789
123456789
123 45 6789
123-45-6789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end