const regex = /^\d{2}-\d{7}$|\d{9}|\d{3}(?<sep>[-\s])\d{2}\k<sep>\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{2}-\\d{7}$|\\d{9}|\\d{3}(?<sep>[-\\s])\\d{2}\\k<sep>\\d{4}', 'gm')
const str = `12-3456789
123456789
123 45 6789
123-45-6789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}