import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{2}-\\d{7}$|\\d{9}|\\d{3}(?<sep>[-\\s])\\d{2}\\k<sep>\\d{4}";
final String string = "12-3456789\n"
+ "123456789\n"
+ "123 45 6789\n"
+ "123-45-6789";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}