#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=%%\[(\s|.)*)\s*(?=(\s|.)*\]%%)"
Local $sString = "" & @CRLF & _
"set Lorem ipsum" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"%%[" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"set @truth = 'this is amp'" & @CRLF & _
"" & @CRLF & _
"IF @truth == 'this is amp' THEN" & @CRLF & _
"set @response = 'amp rocks'" & @CRLF & _
"ELSE" & @CRLF & _
"set @response = '️...'" & @CRLF & _
"ENDIF" & @CRLF & _
"" & @CRLF & _
"]%% " & @CRLF & _
" " & @CRLF & _
"set Lorem ipsum" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")