$re = '/(?<=%%\[(\s|.)*)\s*(?=(\s|.)*\]%%)/m';
$str = '
set Lorem ipsum
%%[
set @truth = \'this is amp\'
IF @truth == \'this is amp\' THEN
set @response = \'amp rocks\'
ELSE
set @response = \'️...\'
ENDIF
]%%
set Lorem ipsum
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);