import re
regex = re.compile(r"(?<=%%\[(\s|.)*)\s*(?=(\s|.)*\]%%)", flags=re.MULTILINE)
test_str = ("\n"
"set Lorem ipsum\n"
" \n"
" \n"
"%%[\n\n\n"
"set @truth = 'this is amp'\n\n"
"IF @truth == 'this is amp' THEN\n"
"set @response = 'amp rocks'\n"
"ELSE\n"
"set @response = '️...'\n"
"ENDIF\n\n"
"]%% \n"
" \n"
"set Lorem ipsum\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")