#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/(?!.*index|$)"
Local $sString = "www.mydomain.com/funny-cat-videos" & @CRLF & _
"www.mydomain.com/enginerebuild" & @CRLF & _
"www.mydomain.com/mcmeme" & @CRLF & _
"www.mydomain.com" & @CRLF & _
"www.mydomain.com/index.php" & @CRLF & _
"www.mydomain.com/index.php?m=new&etcetc" & @CRLF & _
"www.mydomain.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")