$re = '/\/(?!.*index|$)/m';
$str = 'www.mydomain.com/funny-cat-videos
www.mydomain.com/enginerebuild
www.mydomain.com/mcmeme
www.mydomain.com
www.mydomain.com/index.php
www.mydomain.com/index.php?m=new&etcetc
www.mydomain.com/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);