re = /\/(?!.*index|$)/m
str = 'www.mydomain.com/funny-cat-videos
www.mydomain.com/enginerebuild
www.mydomain.com/mcmeme
www.mydomain.com
www.mydomain.com/index.php
www.mydomain.com/index.php?m=new&etcetc
www.mydomain.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end