const regex = /\/(?!.*index|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(?!.*index|$)', 'gm')
const str = `www.mydomain.com/funny-cat-videos
www.mydomain.com/enginerebuild
www.mydomain.com/mcmeme
www.mydomain.com
www.mydomain.com/index.php
www.mydomain.com/index.php?m=new&etcetc
www.mydomain.com/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}