using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+((-\w+)|(\.\w+))*\@[A-Za-z0-9]+((\.|-)[A-Za-z0-9]+)*\.[A-Za-z0-9]+$";
string input = @"me@too.dk
me.too@meee.dk
me,too@meee.dk
me.too@meee,dk
me-too@meee.dk
me.too.tt@meee.dk
me.too@meee.uk.dk
me.too@meee.co.dk";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}