import re
regex = re.compile(r"^\w+((-\w+)|(\.\w+))*\@[A-Za-z0-9]+((\.|-)[A-Za-z0-9]+)*\.[A-Za-z0-9]+$", flags=re.MULTILINE)
test_str = ("me@too.dk\n"
"me.too@meee.dk\n"
"me,too@meee.dk\n"
"me.too@meee,dk\n"
"me-too@meee.dk\n"
"me.too.tt@meee.dk\n"
"me.too@meee.uk.dk\n"
"me.too@meee.co.dk")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")