using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"sbermarket\.ru\/(metro|lenta|auchan)";
string input = @"sbermarket.ru/metro
sbermarket.ru/lenta
sbermarket.ru/auchan
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}