package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)sbermarket\.ru\/(metro|lenta|auchan)`)
var str = `sbermarket.ru/metro
sbermarket.ru/lenta
sbermarket.ru/auchan
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}