re = /sbermarket\.ru\/(metro|lenta|auchan)/m
str = 'sbermarket.ru/metro
sbermarket.ru/lenta
sbermarket.ru/auchan
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end