$re = '/sbermarket\.ru\/(metro|lenta|auchan)/m';
$str = 'sbermarket.ru/metro
sbermarket.ru/lenta
sbermarket.ru/auchan
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);