#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\D|^)(\d{6})(?=\D|$)"
Local $sString = "abc12345 - no match, less than 6 consecutive digits" & @CRLF & _
"" & @CRLF & _
"abc123456 - i need to match only this string and return 123456" & @CRLF & _
"" & @CRLF & _
"abc1234567 - no match, more than 6 consecutive digits" & @CRLF & _
"" & @CRLF & _
"abc12345678 - no match, morethan 6 consecutive digits"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")