$re = '/(?<=\D|^)(\d{6})(?=\D|$)/m';
$str = 'abc12345 - no match, less than 6 consecutive digits
abc123456 - i need to match only this string and return 123456
abc1234567 - no match, more than 6 consecutive digits
abc12345678 - no match, morethan 6 consecutive digits';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);