using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\D|^)(\d{6})(?=\D|$)";
string input = @"abc12345 - no match, less than 6 consecutive digits
abc123456 - i need to match only this string and return 123456
abc1234567 - no match, more than 6 consecutive digits
abc12345678 - no match, morethan 6 consecutive digits";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}