using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)incident:(\w.*),eid:(\w.*),domain:(\w.*),contact:(\w.*)";
string input = @"incident:reset my password,eid:emmanuel.z.m.deluyas,domain:accenture@com,contact:09668674472";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}