// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)incident:(\w.*),eid:(\w.*),domain:(\w.*),contact:(\w.*)").unwrap();
let string = "incident:reset my password,eid:emmanuel.z.m.deluyas,domain:accenture@com,contact:09668674472";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}